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1. Introduction  
WCEN is a fiber diffraction data processing program. The main features of the program 
include displaying fiber diffraction images, determining fiber diffraction parameters, 
refining the parameters, correcting systematic effects and mapping diffraction data into 
reciprocal space.  
 
We assume that the users are familiar with X window environment and understand basic 
window operations.  

1.1 Formatting Conventions 
In this manual, there are several formatting conventions used to denote the different on 
screen interface commands.  
 

• Bold indicates a command to click, such as buttons, options and drop down menus.  
• SMALL CAPS indicate a new window opening on top of the main image window. 
• Italics indicate a pane or input box within a window or a sub-window. 
• Courier font is used for typed commands and on-screen text. 

1.2 File Browser Windows 
All files loaded and some saved in WCEN use a file 
browser window (see Fig. 1). There are four input 
fields and navigation tools – the Directories pane, 
Filter box, Files pane, and File box. You may click 
the Cancel button at anytime to close the browser 
window without loading or saving a file. 

1.2.1 Loading a file in the browser window 
1) Select the folder with the desired file in the 

Directories pane. 
2) In the Filter box, use a wildcard command (*) 

to select the file extension you want to 
display in the Files pane. Click Filter to 
apply the criteria. 

3) In the Files pane, select a file to load with the 
mouse. 

4) The selected file will appear in the Files box, 
click the OK button. 

1.2.2 Saving a file in the browser window 
1) Select the destination folder with the Directories pane.  
2) Type the file name in the File box with the desired extension. 
3) Click the OK button. 

Fig. 1. A File Browser window 
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1.2.3 Directories Pane 
Use the Directories pane to navigate folders. In the Directories pane, select a folder by 
highlighting it with the mouse. The selected directory will then appear in the Filter box. 
Double clicking on a directory will act like the Filter button, and show the files from the 
Filter box in the Files Pane. Double clicking the directory ending /.. takes the user up 
one level in the file hierarchy. 

1.2.4 Filter Box 
The Filter box can select specific file extension types to appear in the Files pane by using 
wildcards (*). Wildcards ignore text before or after them, some examples of use:  

Filter box input Files displayed in Files pane 
/Users/Fiber/images/*.smv all .smv files in /Users/Fiber/images 

/Users/Fiber/NMV* files in /Users/Fiber/ beginning with NMV 
/Users/Fiber/images/* 

 
all files in /Users/Fiber/images 

/Users/Fiber/images/*284* files in /Users/Fiber/images with 284 in their name 

Click Filter to implement the wildcard constraints from the Filter box. 

1.2.5 Files Pane 
The Files pane will display filtered files from the Filter box or Directories pane. Click and 
highlight a file in this pane to write that file name into the File box for imminent selection. 

1.2.6 File Box 
The file name shown in the Files box will be loaded or saved. Click OK to load or save 
respectively. A progress bar will appear while loading image files. 

1.3 File Naming Conventions 
Users who wish to take advantage of WCEN’s default filters should use these extensions 
for parameter and colormap files respectively. 

.par default naming conventions for parameter files 
.cmp default naming conventions for colormap files 
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2. Main Program Window 
When first started, the main window of the program will come up. It has three parts, a title 
bar, a main menu bar and the image window.  

2.1 Title Bar 
The title bar is the very top bar of the program window. The title bar contains the name of 
the current version of WCEN, the name of the file last loaded and the width and height of 
the image in the image window. The title bar will also have close, minimize and maximize 
buttons that will vary depending on the operating system used. 

2.2 Main Menu Bar 
The main menu bar is immediately below the title bar and consists of seven drop down 
menus: File, Image, Colormap, Draw, Process, Windows, and Help. The menus will be 
discussed in order later in the manual. 

2.3 Main Image Window  
The main image window (Fig. 2) is 
used to display the fiber diffraction 
image. PseudoColor is used for 
efficient manipulation of colormap 
and image refreshing. There is 
virtually no restriction on the size of 
the image. Vertical and horizontal 
scroll bars can be used to scroll 
images through the window when 
the image is very large. Furthermore, 
the main window is revisable. There 
is a cross-box type cursor in the 
image window. The pixel position 
and intensity of the cursor position 
are shown in the window's title bar. 
Clicking the mouse button, or 
dragging the mouse while holding 
the mouse button down, changes the 
cursor’s position.  
 
It should be noted that the key shortcut (an underscored letter) might not work on some 
systems. On Red Hat Linux, pressing ALT + a shortcut letter would activate the 
corresponding top-menu, and subsequent pressing of a shortcut letter in the sub-menu 
would invoke the corresponding command; on Mac OS X systems, the top-menu shortcut 
doesn't work because X Windows absorbs the ALT input, but the sub-menu shortcut still 
behaves the same.  

Fig. 2  MAIN IMAGE window 
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3. File Menu 
The File menu allows users to Open, Save and Close image files, Load Parameters and 
Save Parameters and Exit WCEN. 

3.1 Open command 
Go to the File menu and choose Open to bring up the file browser window OPEN IMAGE.  
The image formats currently supported in WCEN are listed below: 
 

Format Description 

BSL (CCP13) This image format has a header file (xxx000.xxx) for image size and 
other information, and a binary file (xxx001.xxx) for image data.  

MAR image plate  This image format includes 4000 bytes of header information followed 
by a 16 bit image data.  

Perkin Elmer 
Head information and image data are stored in two separated files. The 
image data are stored as 12-bit pixels. Any pixel with a value greater 
than 2400 is considered saturated. 

Raw image Image height and width, header size, bytes per pixel, and data type 
(unsigned, signed or float) must be specified before reading the image. 

RAXIS (MSC) Molecular Structure Corporation’s X-ray diffraction Image format for 
R-axis IV. Image size and other information are included in the file. 

SMV image File format for ADSC CCD detectors. Image information is included in 
the header. 

SPR image Text image produced by Fit2d 

TIFF 8,16-bit grayscale or 24-bit color TIFF image (without compression). 
Image information is included in the header. 

 
See the Introduction for help navigating the file browser window. 
 
Changing Image Format: In the 
OPEN IMAGE window, click the 
Options button to bring up the 
IMAGE FORMAT window (Fig. 3). 
Click the select format drop 
down button and select one of 
the image formats listed above. 
Click the OK button to change 
format or the Cancel button to 
ignore any changes. The selected 
format will be displayed above 
the Image File text box. 
 

Fig. 3. IMAGE OPTIONS window 
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To load an image with an unlisted format (or no header), Raw image may be used. In this 
case, you need specify all of the following for your image: image width and image height 
(both in pixels), bytes in header, bytes per pixel, and type of image data (unsigned, 
signed, or float point number). For example, images in MAR image plate format can be 
loaded as Raw image format with a bytes in header of 4000 and bytes per pixel of 2.  
 
There is an additional swap byte option available for Raw image and BSL image. When it 
is checked, WCEN will swap the byte order of the image data. Byte order is a concern 
when you transfer data across computers, for they might store numbers in a different way. 
For example, Intel X86 based systems (e.g. Linux and Windows PC) store the lower-order 
byte of a number at the lower memory address (Little Endian), while Mac and most UNIX 
systems store the higher-order byte of a number at a lower address (Big Endian). The 
following table lists the endianess of popular computer systems: 

Processor Type Operating System Byte Order 
Alpha AXP Tru64 Unix Little Endian 
 Alpha VMS Little Endian 
 Linux Little Endian 
HP PaRISC HP-UX Big Endian 
IBM RS/6000 AIX Big Endian 
Intel X86 Linux Little Endian 
 Solaris X86  Little Endian 
 Windows Little Endian 
 Intel Macintosh OS X Little Endian 
Motorola PowerPC Macintosh OS (Classic)  Big Endian 
 Macintosh OS X Big Endian 
SGI R4000 and up IRIX Big Endian 
Sun Sparc SunOS Big Endian 
 Solaris Big Endian 

3.2 Save as 
Go to the File menu and select Save as; choose one of the image formats to save the image 
to a file. The following are the sub-menu commands under the Save image command: 

 

smv save image in .smv format 
bsl save image in .bsl format 

8-bit grayscale tiff save image in .tiff format (8-bit grayscale, no compression) 
16-bit grayscale tiff save image in .tiff format (16-bit grayscale, no compression) 

24-bit color tiff save image in .tiff format (24-bit color, no compression) 
8-bit raw save image in an array of pixels (1 byte per pixel), no header 

16-bit raw save image in an array of pixels (2 bytes per pixel), no header 
rad save polar coordinates in txt file for angular deconvolution 

postscript save image in postscript format (.ps) 
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3.3 Close 
To close the image currently open in the main image window, go to the File menu and 
click Close. This command will not exit WCEN. 

3.4 Load Parameters 
Open the File menu and choose Load Parameters to read a file of fiber diffraction 
parameters and reflections. The Load Parameter browser window will open (see section 
1.2.1). The default file type is .par for parameter files. If the size of the image in the 
parameter file is different from that loaded in the main image window, a warning message 
will appear on the screen to notify the user. A similar command is found in the Parameter 
menu of the REFLECTION-PARAMETER window (see section 8.2.2.8). 

3.5 Save Parameters 
Open the File menu and choose Save Parameters to write the latest fiber diffraction 
parameters and reflection list to a file. The SAVE PARAMETER browser window will open 
(see section 1.2.2). The default file type is .par for parameter files. Users should use this 
command to backup parameters periodically. A similar command is found in the Parameter 
menu of the REFLECTION-PARAMETER window (see section 8.2.2.9). 

3.6 Exit 
To close the main window and exit WCEN, open the File menu and choose Exit. Before 
closing the program, be sure to save any changes to image data or parameters. 
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4. Image Menu 
The Image menu allows users to Flip or Rotate images, Repair small areas of an image 
with a smoothing function, Merge a second image with the current one, and Rescale the 
intensities (mainly designed to work with the fiber diffraction simulation program 
Disorder, http://fibernet.vanderbilt.edu/Software/disorder). 

4.1 Flip 
In the Image menu select Flip; from the sub-menu that appears choose vertically or 
horizontally to flip the image in the selected manner. 

4.2 Rotate 
In the Image menu select Rotate; from the sub-menu that appears choose 90 degree, 180 
degree, or 270 degree to rotate the image clockwise by the amount selected. 

4.3 Repair 
WCEN can remove image defects caused by detector malfunction. The removal program 
takes a defined rectangle of pixels and revalues the intensities using a simple smoothing 
function based on the pixel intensity values immediately outside the defined area. 
Smoothing occurs across the narrowest direction of the rectangle defined. This function 
works best for a row or column of bad pixels. 

4.3.1 Steps for Removing an Image Defect 
1) In the Image menu, click Repair to open the IMAGE REPAIR window.  Click Show 

Pixels in the IMAGE REPAIR window to open the PIXEL INTENSITIES window. 
2) In the Main Image window, drag the cursor to the top left region of the defective 

area. 
3) Use the PIXEL INTENSITIES window to identify the edge of the defective pixel 

region – for lines of bad pixels note the one (or ones) that systematically differ as a 
column or row. 

4) Enter the x/y coordinates of the top left corner of the region to be corrected in the 
boxes x1 and y1 of the IMAGE REPAIR window.  

5) Repeat steps 2-4 for the bottom right corner and enter the x/y coordinates of the 
bottom right corner of the region to be corrected in the boxes x2 and y2 of the 
IMAGE REPAIR window. 

6) Click Repair in the IMAGE REPAIR window. 

4.3.2 Exiting the Repair function 
In the IMAGE REPAIR window click Close. 
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4.4 Merge 
From the Image menu click Merge to 
open the MERGE window (Fig. 4).  

4.4.1 Input Image 
To select an image to merge, click the 
Browse button to locate the image file. 
Click the Preview button to view the 
image. If the image contains only one 
quadrant of a pattern, check the 
corresponding radio button.  

4.4.2 Merge Operations 
Drag the scalebar to change the ratio 
of the two images for merging. By 
default, all 4 quadrants of both images 
are used, and the merged image is 
shown in the main window. Click 
Merge button to start the merging. The Save button saves the current image in display, 
while the Restore button restore the image in display to the last saved.  

4.5 Rescale 
From the Image menu click Rescale to open the 
RESCALE window (Fig. 5). This function is 
designed to optimize the contract of a simulated 
pattern from the program Disorder, by varying the 
scale factors for the calculated intensities, and the 
temperature factors.  

4.5.1 Rescale Parameters 
By default all 4 quadrants are rescaled. To vary the 
temperature factors, the pattern has to be in 
reciprocal space, and the Pixel size has to be 
defined. The text boxes below a scalebar indicate 
the minimum and maximum values of the scalebar, 
and can be manually changed.  

4.5.2 Rescale Operations 
Dragging the scalebar to rescale the image. Click 
Anisotropic to bring out the anisotropic box to vary 
temperature factors in R and Z directions. The Save 
button saves the current image in display, while the 
Restore button restore the image in display to the last 
saved.  

Fig. 4. MERGE window 

Fig. 5. RESCALE window 
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5. Colormap Menu 
The Colormap menu allows users to Customize colormaps, Save colormaps, and Load 
them from a file. 

5.1 Load 
From the Colormap menu, select Load to open a file browser window. The default 
wildcard filter is *.cmp in the Filter box. Refer to section 1.2, for assistance with the file 
browser. 

5.2 Save 
In the Colormap menu, click Save to open a file browser window. Type the file name in 
the Write Colormap File box after the directory name. The file browser filter default is 
.cmp, so users should use this file suffix if they wish the saved file to show up with the 
default configuration. The histogram range, colormap and the polynomial function are 
saved across colormap control sessions. 

5.3 Customize 
From the Colormap menu click 
Customize to open the COLORMAP 
CONTROL window (Fig. 6). This window 
has three control features: a drop down 
menu for select colormap, a Histogram 
pane, and a Colormap pane. 

5.3.1 Colormap Selection 
In select colormap drop down menu, 
click on one of the options (Rainbow is 
the default). WCEN has eleven 
colormap options and users should 
experiment with the available maps to 
achieve the best imaging of their data. 
Two of the colormap options, Keiichi 
and Green-Purple, are banded maps; all 
other maps are smooth. Changes made 
in select colormap are shown 
immediately in the main image window. 

5.3.2 Histogram Pane 
In the histogram pane, the white histogram represents the intensity distribution of the 
diffraction data. The horizontal axis is the intensity axis and the vertical axis is intensity 
frequency. Underneath the histogram pane are two input boxes; the left box is an input for 
the intensity range lower limit and the right box is the upper limit. Changes in these boxes 

Fig. 6. COLORMAP CONTROL window 
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will be reflected by the vertical histogram lines in the histogram pane and by the intensity 
range of the colormap pane. Moving the histogram lines in the histogram pane will also 
change the intensity range of the colormap pane. To move a histogram line, click the 
mouse pointer on the line without releasing the button and move the line by dragging the 
mouse to a desired position before releasing the button. Right-click (or Option-click) to 
“release” a line so that you can move the other histogram line. Click the Apply button at 
the bottom of the COLORMAP CONTROL window to modify the intensity display range of 
the colormap pane. 8-bit image data have to be re-calculated to reflect the change of 
intensity display range. Calculating 8-bit image data may take much more time than 
changing the CCC depending on the size of the image. 

5.3.3 Colormap Pane 
The colormap pane displays the currently selected map. The horizontal axis of this pane is 
the intensity range of the colormap and the vertical axis is the range of different colors 
offered by the selected map. Below the pane at either end are two numbers that represent 
the intensity display range, which can be modified in the histogram pane (section 5.3.2).  
 
In the colormap pane, there is a white line going across the pane called the color control 
curve (CCC). Manipulating the CCC changes the colors at any given intensity. The default 
CCC is a straight line with three control points marked with open square boxes. Dragging 
any one of the square boxes on the curve alters the CCC. A control point can be added or 
removed by clicking the middle or right mouse button, respectively (option-click and 
“apple”-click for a Mac mouse): 

CCC Action 3 button mouse  1 button mouse  
move control box Left button Mouse button 

add control box Center button Opt + Mouse button 
remove control box Right button  + Mouse button 

Only ten control points can exist in the pane at a time, including the boxes at the ends. The 
control points at the ends of the curve cannot be removed, but can slide up and down the y-
axis.  
 
To restore the last saved settings, click the Reset button in the COLORMAP CONTROL 
window. Click the OK button to accept the new CCC and close the window. Click the 
Cancel button to restore the default CCC and close the window.  
 
Tip: The control points are fixed points on the CCC, with the line curving as a polynomial 
function. Because of their nature, you cannot slide control points horizontally past other 
control points. The position of the CCC on the vertical axis assigns color to the intensity on 
the horizontal axis. Also, control points close to each other will tend to create large slopes 
and thus abrupt or radical changes to the colormap. Thus, use of many control points on a 
smooth colormap can create the effect of a banded colormap (Keiichi or Green-Purple). 
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6. Draw Menu 
The Draw menu allows users to draw a Circle, a Resolution Circle or Layerline. This 
menu also allows users to Move Objects, Refresh, and Close All objects. 

6.1 Circle 
From the Draw menu click Circle to open the 
DRAW CIRCLE popup window (Fig. 7). This 
window has a color display area, a scalebar, a 
palette, an input field for radius (in pixels), two 
arrow buttons for increment/decrement of the 
radius, and an input field for step size (in pixels). 
The color selected area shows the current color 
for drawing, and it can be changed by dragging 
the scalebar or clicking the palette. After 
selecting color, enter the radius (in pixels) to 
draw a circle (from the pattern center) onto the 
main image window. The default value in the 
radius box is the radius from the last cursor 
position to the pattern center. Drawing circle is 
useful in determining the specimen to detector 
distance (see section 8.2.2.4), and helpful in 
identifying symmetry related reflections. The 
Clear button will clear the last drawn circle.  

6.2 Resolution Circle 
From the Draw menu click Resolution Circle to open the DRAW RESOLUTION CIRCLE 
window. The window is similar to Draw Circle, except that the radius unit is Å and the 
default value is the resolution of the last cursor position.  In order to draw a resolution 
circle, the parameters distance, wavelength, and raster must be defined (section 8.1.1). 

6.3 Layerline 
From the Draw menu click Layerline to open DRAW LAYERLINE Window. The drawing 
interface is similar to that of Circle, except that the repeat (Å) box is for fiber repeat. In 
order to draw layerlines, the parameters distance, repeat, wavelength, and raster must be 
defined (section 8.1.1). Layerlines are calculated using the most recent parameter values. 
This is a very useful option for checking the accuracy of the parameters, because a 
mismatch between the layerlines and the diffraction pattern indicates errors in the 
parameters. However, caution should be taken for a diffraction pattern with severe 
layerline splitting, such as tobacco mosaic virus. In this case, mismatch may not indicate 
errors in the parameters. 
 
Tip: Drawing an additional set of layerlines at 90 degrees from the refined twist parameter 
will give a grid showing the refined center. This is useful for visualizing the image center. 

Fig. 5 DRAW CIRCLE window 
 

Fig. 7. DRAW CIRCLE window 
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6.4 Move Objects 
From the Draw menu click Move Objects to open 
MOVE OBJECTS/CENTER window (Fig. 8) and it can be 
also accessed from the REFLECTION-PARAMETER 
window (Section 8.2.2.3). This allows you to move the 
center of the diffraction pattern, redrawn the objects 
(circles, resolution circles and layerlines) and watch the 
fit. Move can be done with either the arrow buttons on 
the window, or the arrow keys on your keyboard once 
you check enable move by arrow keys.  Please note 
that you need to put the focus back into main image 
window in order to move objects using the arrow keys. 

6.5 Refresh 
In the Draw menu choose Refresh to redraw the 
current objects on the main image.  

6.6 Clear All 
In the Draw menu choose Clear All to erase all the objects drawn on the main image. 

Fig. 8. MOVE OBJECTS window 
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7. Process Menu 
The Process menu has three options, Plot, Correction and Transform. Correction 
compensates for film absorption, incident beam type, and detector fog/dark current. 
Transform is used for changing image data into reciprocal, polar reciprocal or RAD-
Polar-reciprocal formats. 

7.1 Plot 
In the Process menu click Plot to open the DATA PLOT window (Fig. 9). It consists of three 
panes: the Object pane, the Plot pane and the Command pane. 
 

 
 
 

7.1.1 Object Pane 
Five types of objects can be selected in the main window. To select a line, left-click the 
starting point, drag the mouse pointer to the end point, and left-click. To select a radi, drag 
mouse pointer and left-click. To select an azim, i.e., an arc, left-click the starting point, 
then drag the mouse pointer to draw the arc, and left-click to stop. To select a circ(le),  
drag the mouse pointer to draw and left-click to stop at desired radius. To select a box, left-
click the starting point (top-left corner of the box), drag the mouse pointer to the end point 
(the bottom-right corner of the box) and left-click. Data points are picked to be the nearest 
pixels if not exact. For a box, data are collected along its long dimension and averaged 
along the short dimension.  

Fig. 9. PLOT window 
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7.1.2 Plot Pane 
The data plot can be zoomed and saved, see 7.1.3.  

7.1.3 Command Pane 
To plot data, select an object from the main image, and then click the Plot button; to zoom 
the plot, draw a box on area of interest; to undo a zoom, click the Undo button; click the 
Type button to switch the type of the plot between line, line with data points, and data 
points only; to save the plot data or picture into a file, click the Save button; to clear the 
plot and clear all plot objects in the main image, click the Clear button. 

7.2 Correction 
In the Process menu click Correction to 
open the DATA CORRECTION window (Fig. 
10). The window consists of three panes: the 
Absorption pane, the Polarization pane and 
the Detector Fog pane. At the top of each 
pane, there is a toggle button. When the 
toggle button is off (in red), the 
corresponding pane is collapsed and the 
systematic effect will not be corrected for 
the data. When the toggle button is on (in 
green), the corresponding pane is expanded 
and the systematic effect will be corrected 
for the data. 
 
All the experimental parameters must be 
determined or defined before any correction 
can be made. The corrections must be made in 
detector space. After selecting the appropriate 
conditions, click Apply in the DATA CORRECTION window to correct for the selected 
factors. Click Cancel to exit Correction and close the DATA CORRECTION window. 

7.2.1 Absorption Pane 
WCEN includes preset mass absorption coefficients (ke and kb) for several film types. To 
select a provided film type, go to the Absorption pane and click the film type drop down 
menu to select KODIREX (Kodak), ILFORD, CEA, and Kodak NoScreen. Selecting a 
preset film type enters the correct emulsion (ke) and base (kb) values into the absorption 
coefficients boxes.  
 
Non-listed film types can be corrected in the Absorption pane. In the Absorption pane, go 
to film type and from the drop down menu select Other. Now enter the correct emulsion 
(ke) and base (kb) values into the absorption coefficients boxes.  
 
Select film pack sequence if you wish to correct for x-ray absorption of film pack 
wrappers and other film packs. The toggle buttons A, B, C, and D correspond to the 

Fig. 10. DATA CORRECTION window 
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sequence of film packs out of four stacked together. Use A if only a single film pack was 
used. 
 
Non-linearity due to the limited dynamics range of films is also corrected (Phillips, et al., 
J. Appl. Cryst. (1985). 18, 3-7). The correction parameters are built into the program.  
 
This only applies to data when photographic films were used. The absorption of an oblique 
incident beam by films must be corrected for by a factor of C(0)/C(τ). For a double side 
film C(τ) has the following form (Fraser, et al., J. Appl. Cryst. (1976). 9, 81-94):  

C(τ) = 1 - exp ( -ke sec τ) + exp [ -(ke + kb) sec τ] - exp [ - (2ke + kb) sec τ] 
where τ is the angle between diffraction vector and the normal of the detector.  

7.2.2 Polarization Pane 
In the Polarization pane, three types of incident beam can be chosen from the drop-down 
menu: Unpolarized, Polarized, or Synchrotron. The current version of WCEN provides 
polarization correction for three types of radiation: unpolarized X-ray beam, crystal-
monochromatized X-ray beam, and highly polarized synchrotron X-ray beam.  
 
For unpolarized X-ray beam, the correction factor can be found from any X-ray 
crystallography textbook:  

(1 + cos2 2θ) / 2 
where 2θ is the Bragg angle.  
 
For crystal-monochromatized X-ray beam, the correction factor is given by (Azaroff, Acta. 
Cryst. (1955). 8, 701-704):  

! 

cos
2
2" 'cos2 # + sin2 #( )cos2 2" + cos2 2" 'sin2 # + cos2 #

1+ cos2 2" '
 

where 2θ' is the Bragg angle of the monochromator, and ρ is the “dihedral angle” between 
the incident beam (into the monochromator) and the diffracted beam (by the specimen).  
  
For polarized synchrotron X-ray beam (with a monochromator), the correction factor is 
given by (Kahn et al., J. Appl. Cryst. (1982). 15, 330-337): 

(1 + cos2 2θ) / 2  -  (τ' cos 2ρ sin2 2θ) / 2  
where ρ is the same as in the case of crystal-monochromatized beam, and τ' is a factor 
depending on the monochromatic crystal and synchrotron radiation source. τ' is usually 
very close to 1, and you should be able to obtain its exact value from your synchrotron 
source staff. 
 
Please note that for the crystal-monochromatized beam and the synchrotron beam, ρ varies 
with each reflection. What WCEN asks for, ρ', is the angle between the incident beam (y0) 
and the upper vertical axis of the detector (z), which is constant. ρ' is positive if y0 is to the 
left of z, negative otherwise. WCEN calculates ρ by adding the angle between the 
reflection and vertical axis to ρ'.  
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7.2.3 Detector Fog Pane 
To correct for detector fog, toggle on the Detector Fog pane and enter a value into the 
offset box. WCEN can automatically enter a value using the Detector Fog command in the 
Parameter menu of the REFLECTION-PARAMETER window. See section 8.2.2.6 for details. 

7.3 Transform 
WCEN can map images in the main image 
window from detector space into reciprocal 
space. From the Image menu choose 
Transform to bring up the DATA 
TRANSFORMATION window (Fig. 11) Under 
Transformation Type WCEN provides three 
options: Cartesian reciprocal, polar 
reciprocal, and polar reciprocal for angular 
deconvolution. Select the desired 
transformation by switching the appropriate 
toggle button to green. By default, symmetry 
equivalent data from four quadrants will be 
merged/averaged in the transformation, to turn 
this option off, set the toggle button under 
Merge Data to none. Resolution Range (lower 
and upper, in Å) and reciprocal Bin Size (x-rad 
and y-angle) values can be specified or changed 

in the appropriate text box. Resolution Range 
defaults to a lower limit of 1000 Å and upper 
limit of 2.500 Å for all transformation types.  

7.3.1 Cartesian Reciprocal Transform 
This option transforms image from detector space into Cartesian reciprocal space. The bin 
is a square in reciprocal space and is defined by the Bin Size text box x-rad. The bin size 
unit is Å-1 and is determined by the value in the x-rad box. The value of y dimension of the 
bin in reciprocal Cartesian transformation has no effect on the size of the bin. 

7.3.2 Polar Reciprocal Transform 
This option transforms image from detector space into polar reciprocal space. The r 
dimension of the bin is in Å-1 whereas the angle dimension of the bin is in degrees. 

7.3.3 Polar Reciprocal Transform for angular deconvolution 
This option transforms image from detector space into polar reciprocal space, in a format 
for use with angular deconvolution. The r dimension of the bin is in detector space pixel 
units whereas the angle dimension of the bin is in degrees. The polar coordinates can be 
saved in RAD format (see section 3.2), which can be used directly by RADPV and other 
related programs. Four quadrants of data are merged after the transformation. After the 
merge, R-sym is reported in the Log window (see section 8.6). The reciprocal image will 
be displayed in the main image window.  

Fig. 11. DATA TRANSFORMATION window 
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8. Windows 
WCEN has many tools and functions that appear as popup windows and are contained in 
the Windows menu. Most important of these is the REFLECTION-PARAMETER window, 
which contains the majority of tools for refining parameters and selecting reflections. The 
REFLECTION-PARAMETER window has three main functional areas, the Reflection pane, 
Parameter pane and the Zoom sub-window. Section 8.1 will familiarize users with these 
functional areas, while section 8.2 will detail menu commands in the REFLECTION-
PARAMETER window. 

8.1 Functions in the REFLECTION-PARAMETER window 
The REFLECTION-PARAMETER window can be opened with just the Parameter pane (the 
PARAMETER window), just the Reflection pane and Zoom sub-window (the REFLECTION 
window), or with both sides open together (the REFLECTION-PARAMETER window). Below 
is a screen shot of the REFLECTION-PARAMETER window, with the main functional areas 
labeled: 

 
 
 

The Reflection pane and zoom sub-window are used for selecting reflections from the 
image loaded into the main window. The PARAMETER PANE is used for refining 
experimental parameters (see section 8.2.2.6). 

8.1.1 Parameter Pane 
In the Windows menu select Parameter to open the Parameter pane in the PARAMETER 
window. If the REFLECTION window is already open, the Parameter pane will be added to 
the already open window. The following fiber diffraction parameters are listed in the pane:  

• x0, y0:   pattern center (pixel location)  
• tilt, twist:   specimen missetting angles (in degrees)  

Reflection sub-window ⇒  

Zoom sub-window  ⇒  
⇐  Parameter pane 

Fig. 12. REFLECTION-PARAMETER window 

Scale bar ⇒  

Threshold bar ⇒  

⇐  Parameter Toggle (ON) 
Reflection List ⇒  
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• distance:   specimen to detector distance (in mm)  
• repeat:   fiber repeat distance (in angstroms)  
• wavelength:  radiation wave length (in angstroms)  
• oY, oZ:   detector missetting angles (in degrees)  
• phi, chi, omega: goniostat setting angles (in degrees)  
• 2 theta:   2-theta angle (in degrees)  
• raster:   pixel size of detector bin or film (in micron)  
• offset:   film fog, dark current, or detector offset 
• calibrant ring: the radius of the calibration additive if any (in angstroms) 

 
Parameter values are edited by changing the numbers in the text boxes. It is not necessary 
to press [Return] to register the changes. Changes to parameters due to refinement will 
be immediately reflected in these boxes.  
 
Warning! distance, repeat, and wavelength are highly correlated. DO NOT refine any 
two or all of these parameters at the same time. DO NOT refine wavelength under normal 
circumstances. 

8.1.1.1 Apply Button 
In the Parameter pane, click the Apply button to read data from the input boxes into 
WCEN. The frequency with which WCEN automatically saves parameter data is system 
dependent, so Apply is used to immediately register input data. This is useful when 
manually changing parameters to fit layerlines (section 6.3). 

8.1.1.2 Parameter Flags 
The parameters WCEN can refine using the Refine selected (see section 8.2.2.7) feature 
have a toggle button to their right. The toggle is engaged when green, disabled when red, 
and can be switched with a mouse click. When using the Refine selected feature, only the 
parameters with the toggle button enabled (in green) will be refined. In default mode, all 
the toggle buttons are disabled. 

8.1.2 Reflection Pane 
In the Windows menu select Reflection to open the Reflection pane in the REFLECTION 
window. If the PARAMETER window is already open, the Reflection pane will be added to 
the already open window. The reflections listed in the Reflection sub-window contains the 
following data:  

X, Y:  center position of the reflection in detector space  
L:   layerline number assigned to the reflection  
R:   reciprocal space R value 
ID:   an ID number assigned to this reflection during indexing 
Th:   threshold value used in reflection centering  
nP:   number of pixels used in reflection centering  

 
In the Reflection sub-window, a single reflection from the list is selected by clicking on it, 
while multiple reflections can be selected by clicking and dragging the mouse over them. 
Discontinuous reflections may be chosen by holding down the Control key while 
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clicking on the reflections. Selected reflections in the list will be highlighted if selected. 
All selected reflections will be marked in the main image window with a small square 
white box. Scroll bars will appear if the reflection data extends beyond the edges of the 
Reflection sub-window. The Reflection pane also contains the Zoom sub-window. 

8.1.3 Zoom Sub-window (Pixel Selection) 
This pane is used to display a small section of the scaled image at the current cursor 
position in the main image window. To change the area of the image, click on the new area 
or drag the mouse pointer to the new area in the main image window. You can also make 
pixel by pixel adjustments to cursor position with the keyboard arrow keys. The Zoom sub-
window image will change in real time with changes to the cursor’s position in the main 
image window.  
 
THE Zoom sub-window can be used to view the image in detail and is used to select pixels 
for other "actions". Pixels in the Zoom sub-window are selected by clicking and dragging 
the mouse cursor without releasing the mouse button to draw a white selection box. All the 
pixels within the box and above the threshold value are selected.  
 
Under the Zoom sub-window are two control bars: the zoom scale control bar (Scale) and 
the pixel threshold control bar (Threshold). To adjust either control bar, click on it with 
the mouse (a dark box will outline the selected bar) and drag the bar or use the left and 
right keyboard arrow keys to change the value above the bar. Scale is used to change the 
scale factor of the Zoom sub-window, which is an integer from 1 to 64. Threshold is used 
to change the threshold value for pixel selection, which is an integer from 0 and 255. The 
pixels in the Zoom sub-window with a value below the selected threshold value are 
changed to the threshold color. 

8.2 Menus in the Reflection-Parameter window 
Experimental parameters including detector origin, specimen to detector distance, 
missetting angles, specimen tilt and specimen twist angles can be determined and refined 
in WCEN. Users select the specific parameters to be refined. Before the refinements are 
carried out, a list of symmetry equivalent reflections must be collected and indexed. For a 
diffraction pattern from a non-crystalline fiber specimen, a reflection is generally referred 
to an intensity peak with a well-defined boundary. The REFLECTION-PARAMETER window 
has all the menus and functions used for selecting reflections and refining diffraction 
pattern parameters.  

8.2.1 File Menu 
In the File menu users can Close the REFLECTION-PARAMETER window or toggle the 
individual panes opened or closed. Commands for the File menu are as follows: 

Open/Close param pane:  Opens or closes the Parameter pane/window 
Open/Close reflxn pane:  Opens or closes the Reflection pane/window 
Close:      Closes the REFLECTION-PARAMETER window 
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8.2.2 Parameter Menu 
The Parameter menu has all the commands directly related to calculation of parameter 
values in the Parameter pane. Users can determine the diffraction pattern Center from 
reflection or the Center from cursor, determine the specimen to detector Distance from 
reflection or Distance from ring, determine Detector Fog, Save into file or Load from 
file parameter values and Refine selected parameter values. 

8.2.2.1 Center From Reflections 
In the Parameter menu of the REFLECTION-PARAMETER window, click Center from 
Reflections to obtain the diffraction center coordinates (shown as x0 and y0 in the 
Parameter pane). It is calculated by a simple averaging of the positions of all currently 
highlighted reflections from the reflection list in the Reflection pane. Only even numbers 
of reflections will be accepted for averaging.  
 
Warning! The center value calculated will be incorrect unless symmetry equivalent sets 
of reflections are chosen. Equatorial reflections may be chosen in sets of two and non-
equatorial reflections in sets of four. 

8.2.2.2 Center From Cursor 
In the Parameter menu of the REFLECTION-PARAMETER window, click Center from 
Cursor to grab the diffraction center coordinates from the current cursor position in the 
main image window. 

8.2.2.3 Center from objects 
In the Parameter menu of the REFLECTION-PARAMETER window, open Center from 
objects window to adjust the center by moving objects to fit the pattern (see Section 6.4). 

8.2.2.4 Distance From Reflection 
In the Parameter menu of the REFLECTION-PARAMETER window, click Distance from 
Reflection to calculate the specimen to detector distance. The radius of the calibration ring 
is calculated by a simple averaging of the distance to center of all currently highlighted 
reflections from the reflection list in the Reflection pane. For this command to function, the 
center must be determined accurately, the radius of the calibration ring must be input 
correctly in the Parameter pane, and the reflection in the reflection list must be from the 
calibration ring. 

8.2.2.5 Distance from Ring 
In the Parameter menu of the REFLECTION-PARAMETER window, click Distance from 
Ring to calculate the specimen to detector distance. The radius of the calibration ring on is 
taken from the radius of the last circle drawn on the pattern by the Circle command of the 
Draw menu in the main image window (see section 6.1).  

8.2.2.6 Detector Fog 
In the Parameter menu of the REFLECTION-PARAMETER window, click Detector fog to 
define a value for offset in the Parameter pane. The value input into offset is the average 
pixel intensity of all pixels currently selected in the Zoom sub-window (see section 8.1.3 
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on selecting pixels). If no selection box is used, all pixels in the Zoom sub-window are 
averaged to determine offset. 

8.2.2.7 Refine Selected 
From the Parameter menu of the REFLECTION-PARAMETER window, click Refine selected 
to refine selected parameters using all the reflections in the list. WCEN uses power 
minimization method for the refinements. The values of the selected parameters will be 
updated and changes are shown in the Parameter pane text boxes after the refinements. 
When using the Refine selected feature, only the parameters with the toggle button 
enabled (in green) will be refined (see section 8.1.1.2). In default mode, all the toggle 
buttons are disabled (in red). Indexing of reflections should be done before parameter 
refinements (see sections 8.2.3.3 and 8.2.3.4).  

8.2.2.8 Load From File 
From the Parameter menu of the REFLECTION-PARAMETER window choose Load from 
file to load fiber diffraction parameters and reflections list from a file. The LOAD 
PARAMETER browser window will open (see section 1.2). A similar command can be found 
under the File menu in the main image window (section 3.4). The default file type for the 
parameter file is .par. 

8.2.2.9 Save Into File 
From the Parameter menu of the REFLECTION-PARAMETER window choose Save into file 
to save fiber diffraction parameters and the current reflections list to a file. The SAVE 
PARAMETER browser window will open (see section 1.2). A similar command can be found 
under the File menu in the main image window (section 3.5). The default file type for 
parameter files is .par. 

8.2.3 Reflection Menu 
All the tools for adding to and deleting from the reflection list as well as indexing 
command are in the Reflection menu. 

8.2.3.1 Box Select 
From the Reflection menu of the REFLECTION-PARAMETER window click Box select to 
determine the weighted center of the selected pixels in the Zoom sub-window and add the 
coordinates to the reflection list of the Reflection sub-window (see section 8.1.2). Pixels 
are selected using the normal selection method in the Zoom sub-window (see section 
8.1.3).  
 
Tip: Select well-defined reflection peaks in the diffraction pattern. A well-defined peak is 
one with a clearly defined boundary and a symmetrical area. Make sure all symmetry 
equivalent reflections are well defined for the selected threshold value. 

8.2.3.2 Mouse Select/Mouse Stop 
From the Reflection menu of the REFLECTION-PARAMETER window click Mouse select to 
determine coordinates by the position of the cursor in the main image window. Once 
Mouse select is activated, each new cursor click in the main image window will add a new 
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reflection at the cursor coordinates to the reflection list. When done using Mouse select, 
return to the Reflection menu and click Mouse Stop. 

8.2.3.3 Index 
Selecting Index from the Reflection menu of the REFLECTION-PARAMETER window will 
bring up the INDEX popup window. Indexing of reflections assigns a layerline number and 
gives an ID number to reflections. The complete process for manually indexing reflections 
is given below.  
 
Steps for Indexing Reflections 

1) Select a reflection or set of symmetrically equivalent reflections from the 
Reflection sub-window. 

2) From the Reflection menu of the REFLECTION-PARAMETER window select Index 
to bring up the INDEX window. In the INDEX window, the weighted center position 
of a reflection in detector space is shown in the top of the window as x, y 
coordinates.  

3) Enter the layerline number in the layerline text box for the shown reflection 
position and an identifying number for the ID text box. It is not necessary to hit 
[Return] to register the changes in the INDEX text boxes. The ID number must 
be the same for all symmetrically equivalent reflections.  

4) Use the Next or Prev buttons to move between selected reflections and enter or 
edit the indices. Alternately, click Apply if all the selected reflections have the 
same indices. Apply will assign the entered indices of the current reflection to all 
selected reflections.  

5) Click Close when you are done indexing the selected reflections. 
 
It is convenient to select only symmetry equivalent reflections when using the Index 
command since all symmetry equivalent reflections have the same indices. Enter the 
indices for the first reflection then click the Apply button to assign the indices to all the 
reflections in the list. Each reflection should have a unique ID number except symmetry 
equivalent reflections, which must have a unique set ID number. 

8.2.3.4 Auto Index 
From the Reflection menu of the REFLECTION-PARAMETER window click Auto index for 
WCEN to calculate the layerline number and assign an ID number to a set of symmetry 
equivalent reflections. The ID number assigned will be the lowest available integer. Auto 
index uses the repeat variable from the Parameter pane and Z (which can be shown in the 
Coordinate panel, see section 8.3) to assign the layerline number. If these parameters are 
not accurate, the layerline designation may be wrong.  

8.2.3.5 Delete 
In the Reflection menu of the REFLECTION-PARAMETER window, clicking Delete will 
remove any highlighted reflections from the Reflection sub-window. The most recently 
deleted set of reflections are temporarily stored and can be restored to the reflection list 
using the Undelete command (see 8.2.3.6). 
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8.2.3.6 Undelete 
From the Reflection menu clicking Undelete restores to the Reflection sub-window the 
reflections removed by the most recent Delete command (see 8.2.3.5).  

8.2.4 Patch Menu 
The Patch menu allows users to alter the intensity of individual image pixels. Users can 
Set pixel value or Erase pixel value, then Make changes permanent or Reset pixel 
value as needed. Patch is useful when trying to box select highly disordered reflections 
close to other reflections. In such a case, the rectangular box often cannot isolate a peak 
unless some pixel intensities are manually removed in the target peak's vicinity. 

8.2.4.1 Set pixel value 
From the Patch menu click Set pixel value to alter the intensity of the selected pixel or 
pixels. Use the Zoom sub-window to box select the pixels to be altered (section 8.1.3). 
Next, click Set pixel value to open a popup window where you can specify a new pixel 
intensity in the enter pixel value text box. Click Apply in the window and the pixel values 
will be set to the specified value. 

8.2.4.2 Erase pixel value 
The Erase pixel value command will set the selected pixel or pixels to intensity -999. 
Pixel selection is identical to the Set pixel value command (section 8.2.4.1). 

8.2.4.3 Make changes permanent 
Make changes permanent will make the effects of all previous Patch menu operations 
permanent, that is, you will have to reopen the image to restore the original intensities. 

8.2.4.4 Reset pixel value 
Reset pixel value will restore the original intensities for the pixels you have altered 
provided that Make changes permanent has not been applied. 

8.2.5 Help Menu 
In the Help menu of the REFLECTION-PARAMETER window, click Parameter Definition to 
open the PARAMETER DEFINITION popup window. This window has a list with definitions 
of the parameters in the Parameter pane (see 8.1.1). To close the PARAMETER DEFINITION 
popup window, click the Close button at the bottom of this window. 

8.3 Coordinate 
From the Windows menu, select Coordinate to open the Coordinate panel at the top of 
the main window (see Fig. 2). The Coordinate panel shows six values for the pixel closest 
to the current cursor position: 
 x: x-coordinate of the cursor   
 y: y-coordinate of the cursor 
 r: cursor to center distance 

I: pixel intensity at cursor 
d: d-spacing  
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R: polar reciprocal radius 
Z: z-coordinates of reciprocal vector 

The values d, R, and Z are calculated from variables in the Parameter pane, so they are 
only as accurate as the refinement. 

8.4 Pixel Intensities 
From the Windows menu, choose Pixel Intensities to bring up the PIXEL INTENSITIES 
window. This window can also be opened from the Image Repair window (see section 
4.3). This window displays the intensity value of pixels in an 11x11 pixel area at the last 
cursor position before the window is brought up. The pixel location is given by x values 
along the top edge and y values along the left edge. Below the pixel table are these 
variables: 

lmax: Maximum intensity value in the displayed area. 
lmin: Minimum intensity value in the displayed area. 
lave: Average intensity value of the displayed area. 
lsig: Standard deviation of intensity values in the displayed area. 

gmax: Maximum intensity value of the entire image. 
gmin: Minimum intensity value of the entire image. 

(l for local; g for global) 
 
These values are not affected by manipulation of the histogram in the COLORMAP 
CONTROL window (section 5.3). The pixel values can be updated to the current cursor 
position by clicking the Update button in the lower left of the PIXEL INTENSITIES window. 
Click the Close button at the bottom right to close the window when finished. 

8.5 Full Pattern 
From the Windows menu, select Full Pattern to open the FULL PATTERN window. The 
FULL PATTERN window will show a smaller version of the entire image with the x,y pixel 
dimensions of the scaled image on the window’s title bar. The FULL PATTERN window will 
have the same orientation as the main image and can be manipulated, along with the main 
image, using Flip and Rotate (sections 4.2 and 4.3). The FULL PATTERN can be resized by 
dragging the bottom right corner of the window with the mouse. To close the FULL 
PATTERN window, go to the Windows menu and click Full Pattern again, or click close 
on the title bar.  
 
Tip: It is very helpful to pull up the full pattern when changing the colormap to see the 
complete effect of the changes. 

8.6 Log 
Go to the Windows menu and click Log to open the Log pane at the bottom of the main 
window. The Log pane will show calculations of WCEN during parameter refinement. To 
close the Log pane, go to the Windows menu and click Log again. 
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9. Help 
WCEN was first released in 2006 (W. Bian, H. Wang, I. McCullough, G. Stubbs. WCEN: 
A Computer Program for Initial Processing of Fiber Diffraction Patterns. J. Applied 
Crystallography, 39:752-756, 2006), and now in version 1.1. The work is supported by 
FiberNet, formally known as Research Coordination Network: Fiber Diffraction from 
Biological Polymers and Assemblies, which is supported by the National Science 
Foundation's Division of Molecular and Cellular Bioscience, through grant MCB-0234001. 
 
We would like to thank the following people for their input and help in WCEN 
development: Prof. Tom Irving, Prof. Joseph Orgel, Dr. Liang Guo, Dr. Srinivas 
Janaswamy, and Dr. Ben Hines.  
 
For manuals, tutorials, and other resources, please visit  
 
http://fibernet.vanderbilt.edu/software/wcen. 
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Appendix 
 
Customizing WCEN 
 
WCEN can be customized through an X resource file to be more effective. The file is 
usually located under directory /etc/X11/app-defaults or /usr/X11R6/lib/X11/app-defaults, 
or within the file .Xdefaults in your home directory. 
 
Here are some customizable resources (Lines beginning with ! are comments): 
 
! 
! supported image format: IFM_BSL, IFM_MAR, IFM_PES, IFM_RAW, IFM_RAV, 
!                         IFM_SMV, IFM_TIF 
! 
! default image format: 
! 
wcen.defaultImageFormat: IFM_SMV 
! 
! 
! predefined colormap: CMP_Rainbow, CMP_Keiichi, CMP_RGB, CMP_BGR, 
!                      CMP_BlackWhite,  CMP_WhiteBlack, CMP_BlueRed, 
!                      CMP_BlueYellow, CMP_CyanRed, CMP_GreenPurple, 
!                      CMP_GreenRed 
! 
! default colormap: 
! 
wcen.defaultColormap: CMP_Rainbow 
! 
! 
! opticalDensityToPixel is used in non-linearity correction to 
! convert optical density to pixel value, if a film is used. 
!       * P-1000 Optronics: 136.0 
!       * Perkin Elmer MicroDensitometer: 1216.0 
wcen.opticalDensityToPixel: 136.0 
! 
! 
 
The rest resources control the look and feel of WCEN and should be customized with 
caution.  
 
 
 


